
MBend V9 Highlights 

This document describes the new features included in version 9 of MBend from Metalix. 
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1 New Flattening Options  

MBend includes an option to flatten the part according to user-defined default tools, per 
material and thickness. (This is in addition to the older option for flattening the part by 
design radius.)  

There is now a RiR column showing the resulting inner radius (replacing the Radii 
table). 

Click the Home tab => Configuration group => Compensation Factor . The Bend 
Compensation Factor Setup dialog box opens. For example: 

 

For more details, see the MBend Bend Compensation section in the online help. 

2 Try Auto-Process  

MBend can now process new parts automatically when it opens a part for processing 
(from 3D, flat, or the New Part Wizard): 

1. MBend looks for Preferred Tools for the part (by machine + material + 
thickness). 

2. If there are Preferred Tools, MBend applies them and searches for bend 
sequences. 

3. If there is a valid bend sequence, MBend calculates a tool setup. 
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4. If there is a valid tool setup, MBend opens the part in the Simulation stage. 

You can set this option when opening a 3D part by selecting Try auto process: 
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You can also set this option when you finish designing a part in the New Part Wizard: 

 

3 Profile Editing Even After Processing 

You can now edit a part's profile after the tooling stage (for parts created in the Profile 
Editor). You can do this when you are processing the part, or after you open an existing 
part you processed previously. 

To make changes in your profile, bend length, flange heights, etc., click the Simulation 
tab => Switch To group => Design: 
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4 Intuitive Profile Designer 

The profile designer has a new look and feel, and is easier to use. You can change the 
profile values by typing them directly in the table: 

1. Click the Home tab => File group => New Part , select New profile, and 
click Next. 

2. In the Edit Profile screen, design the part. 

The editable values appear in a table on the right: 

 

5 Full Support for Multi-V Dies  

MBend automatically simulates the correct multi-V die opening, rotating the die as 
needed. 

5.1 Types of Multi-V Dies 

MBend supports multi-V die tool import and simulation. These dies include: 

• "X" and multiple-V: 
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• Two-V (quick-change, etc.): 

 

• Two-stage hemming: 

 

  

By requiring only one DXF drawing per die, it is now easier to import the multi-V dies. In 
addition, since there is only one die, there is only one set of segments for this die 
(whereas in the past there was a segment set for each V). 

The one multi-V die can be used for both parts of a hemming bend. For example, 
prebend (1) and flatten (2): 

 

Once a die is imported, MBend recognizes all the V openings.  
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In the Multi-V tab you can examine and modify the parameters for each V opening: 

 

5.2 Select by Die Rotation or by I Axis Movement 

When you use an X die, changing Vs is done by rotating the die in place. But for two-
stage hemming dies this is done by moving the lower clamp in the I axis. For this, 
MBend offers the V switch mode setting: 

• By Die Rotation – for X dies, etc. 

• By I Axis Movement – for two-stage hemming dies, etc. 

In addition, for the I axis movement, MBend calculates the precise offset required: 

 

5.3 Auto Tooling Support Per V 

When you run auto-tooling , MBend tries to find a valid solution for each V die 
opening.  
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In this example, MBend finds two good solutions and two failures: 

 

6 Multiple Setup Support 

A part may require a setup that is not valid for the machine. For example, too many 
stations may overhang the machine, or there may not enough segments to create the 
setup. MBend can split the setup into valid sub-setups, and then generate individual NC 
and setup report files for each sub-setup. 

To activate this option, go to Options  => General tab => Various Settings 
section, select Show Setup Management. 

The following example shows how to split a setup.  
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This part has bends with two different radii (1mm and 4mm): 

 

To use two different dies is not possible because there is not enough room on the 
machine to accommodate the two stations required: 
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The solution is to use the Multiple Setup feature to split the setup in two: 

1. Click the multiple setup icon  (at the bottom of the Simulation panel). 

2. MBend analyzes the setup and checks if it can be split. In this case, MBend 
finds two sub-setups: one for the Station 2 hits, and the other for Station 1 hits: 

 

3. Click Generate Setups. MBend creates two sub-setups. 

Setup1 looks like this: 
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Setup2 looks like this: 

 

4. In the Output stage, select All setups. MBend generates two individual NC files: 
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7 Drag Fingers in All Axes 

You can drag the fingers in any direction, not just the Z axis. 

Select one of the fingers, then select Drag by Z/X/R: 

 

As you drag the finger it is highlighted in yellow: 

 

When you drag so far that it "bites" into the part, MBend highlights it in a reddish color: 
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When you release the finger, it snaps to the part's edge: 

 

8 Import Additional CAD Formats 

MBend can now import additional CAD formats: 

• 2D SCPX files from Muratec 

• 3D Parasolid (x_t) 

• 3D SAT 

9 Auto-Sequencing Enhancements 

Auto-sequencing includes these changes. 

9.1 Report No Solution 

When MBend cannot automatically find a solution, it now reports the reason for failure, 
telling you which tools or components caused collisions. This information should help 
you find a better solution. 
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This example indicates problems with the upper tooling, so a different punch (higher, 
gooseneck, etc.) may provide a valid solution: 
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9.2 Part in Machine Rule 

A new auto-sequencing rule allows you to minimize the unwanted situation where a part 
is positioned inside the machine. For example: 
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 NOTE: You must select Use rule set in auto-sequencing: 

 

9.3 Report All Sequences 

The Report all sequences option in the auto-sequencing setup tells MBend to show the 
results of all sequences; not just the best ones. For example, the second line would not 
normally show up as it requires diagonal gauging: 

 

10 Part Alignment to Tools 

Align the part to the die or punch using the Alignment Management tools in the 
Simulation tab: 
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Options: 

• Align Hit Left and Align Hit Right   move the part to the nearest die or 
punch endpoints on the left or right. 

From this position: 

  
 

Clicking Align Right moves the part to the right of the punch (as it is nearer): 

 

Another click moves it to the right of the die: 

 

• Align Hit Center  moves the part to the middle of the die or punch 
(whichever is closer). 

• Align Station to Machine Center  moves the station to the middle of the 
machine. 

These functions are also all available in the Station Setup (in a slightly different format). 
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 TIP: To align all hits simultaneously, hold down the Ctrl key and click. 

11 Crowning Support for Cybelec 

 For Cybelec-controlled machines. 

The machine configuration can include tonnage percentages for crowning, and Y1 and 
Y2 values. There is no need to calculate the data manually. 

To include this data, in the Machines dialog box, click Output tab => Crowning tab, 
and select Generate Y1, Y2, Tonnage and Crowning output. 

The values in this table are editable. For example: 

 

This is the crowning range from the Cybelec control:  
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These are the values that MBend calculates and outputs to the Cybelec control: 

 

View these values by clicking the Simulation tab => Simulation Configuration group 

=> Hit Parameters . 

12 Import External Bend Compensation Table 

To help you integrate your existing bend compensation data, MBend provides a simple 
interface for managing and importing the values from a CSV file.  

Following is an example of a CSV file (from Solid Edge), open in Excel. Note the column 
headers (MAT, T, V, R, etc.): 

 

1. (Optional) Before importing, map the fields of the CSV file to the relevant fields in 
the bend compensation table. In the Options => Mapping Management tab, 

click the Import Generic Maps tab => Define new CSV map file manually  
and type the Map Property corresponding to each CSV Column. Add columns 

 and delete columns  as required. 

2. To import table headers, click Define new CSV map file from sample file . 
Navigate to the CSV file, then select the Map Property corresponding to each 
CSV Column. Some properties (Material, Thickness, V-Opening, and Radius) 
are mandatory. 
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3. To map the materials, in the Material Synonyms tab, click Define New Material 

Synonym , replace NewSynonym with the name of a material from your 
CSV, and in the Material column, select the corresponding material for use in 
MBend: 

 

At the top of the dialog box:  

o CSV map name is the file you selected. 

o Map Type can only be BendTable. 

o First Data Row indicates where the data begins in the CSV file. 

o Unit can be metric or imperial. 
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 The next action overwrites all the existing values in the table.  

It might be a good idea to make a backup of your environment first. See 
instructions on how to switch the environment (in the Home tab => 
Configuration group).  

4. To import the values, click the Home tab => Configuration group => 

Compensation Factor  and click Import New Bend Table . Select the 
CSV file.  

5. To see the values per material and thickness, in the Bend Compensation 
Factor Setup dialog box, in the Bend Compensation Factor section, select a 
material and thickness from the dropdown lists. The values you imported are 
displayed in the table: 

 

(RiR = resulting inner radius, SB = springback) 
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13 K Display Mode  

The bend compensation table has a new display and edit mode for K factor. Select K in 
the Bend Compensation Factor Setup dialog box, under Display Mode: 

 

The values in the table change, depending on the display mode. 

14 Faster Part Opening 

The speed for opening MBCAM parts in MBend is greatly improved. 

15 Graphical Finger Stop Definitions 

You can define the individual finger stops using an interactive graphic interface.  

1. After importing a finger (or opening it for editing), create a stop by clicking the 3D 
representation of the finger. 

2. For a new cylindrical stop, click the arc of the stop: 
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3. Then click its side: 

 

MBend analyzes the geometry and extracts the stop’s position and attributes 
(height, radius, etc.): 

 

 It is possible to edit all the values manually; for example, if there is no side 
edge to click when defining the stop height. 

For more details, see the video: https://www.youtube.com/watch?v=dDI455d7voQ.  

16 Import\Export Machine Components 

Import and export individual components such as fingers, punches, etc. This feature 
makes it easy to transfer component definitions from one MBend installation to another: 

1. Click the Components tab => the component: 

 

https://www.youtube.com/watch?v=dDI455d7voQ
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2. In the dialog box that opens, click Import  or Export  and follow the 
prompts. The file name extension depends on the type of component (mbmLB 
for lower beams, mbmFR for frames, etc.). 

17 New Post-Processors  

MBend works with additional post-processors:  

• Safan SMK (for older machines) 

• Safan E-Control 

• Euromac  

• CoastOne – TC15  

• Accurpress  

• Cybelec VisiTouch 


